Citroen C4 Cactus Crossover Forum banner
1 - 20 of 35 Posts

Registered
Joined
129 Posts
Discussion Starter · #1 ·
Leaving work last night and started to fell really hot, the heater was on full (manual type heating) so I turned it down, started to feel hot after a few mins, it was back up again! Had an argument with it over the next few miles where I would slide it down and it would slowly slide itself back up to maximum on the screen! It wasn't in demist mode or anything.

I've also got a bizarre phone problem where I choose someone in my contact list and it dials the one below it - even though the name displayed on the screen is correct - it only happens with some people. My phone display shows the real identity.

Quirky car
 

Registered
Joined
735 Posts
What do you expect when a car has been upped to a C4 but based on a C3 :D
 

Registered
Joined
735 Posts
johnm said:
is that supposed to be a helpful reply?
My answer only related to the "Quirky car" part :lol:
 

Registered
Joined
33 Posts
Have you tried cleaning the screen. ION my phones and tabs they can sometimes click back to elsewhere on the screen if there is a bit of dry adhered to them.
 

Registered
Joined
11 Posts
Has anyone else noticed that there is pretty much no feet heat? When directed downwards more comes out of the screen vents and the rear facing floor vent so you end up with hot head and cold feet. Doesn't do that in models with auto climate control but citroen claim it's a "characteristic" of the car!!! Seriously - it's a few flaps!
 

Registered
Joined
38 Posts
I haven't noticed that before but my feet have been cold today even though I had to switch the heater down as my face was burning. I have changed it to only do my feet and will see how that goes.
However I have had an argument with my heater last week. Same as the OP. It was on full hot when I realised I was freezing. Checked it and it had moved down to cold! I moved it back up to full heat but then it switched the direction off my feet and face and just left it on windscreen. So I put those back on and it switched the fan off! I can easily see I might have turned the heating down subconsciously, but I never touch the direction or fan strength normally so I know that wasnt me! :eek:
 

Registered
Joined
644 Posts
Dumb question but do any of the steering wheel buttons operate the heater and we hadn't realised? Can't say i have had any trouble with ours other than it not heating up fast enough on cold mornings!
 

Registered
Joined
1,520 Posts
I was just discussing with my wife how good the heater was, it seems weird at first (on auto) that no air comes out until warm but it kinda makes sense.

We usually leave ours on auto and its around 21 in this weather and it works great. Sometimes if its really raining hard we have to put it onto screen but not often
 

Registered
Joined
133 Posts
Mrsstuzilla said:
Dumb question but do any of the steering wheel buttons operate the heater and we hadn't realised? Can't say i have had any trouble with ours other than it not heating up fast enough on cold mornings!
No! ;)
 

Registered
Joined
735 Posts
Mrsstuzilla said:
Can't say i have had any trouble with ours other than it not heating up fast enough on cold mornings!
Have you tried keep touching the + sign until it says "Hi" ? There's also a "Lo" for the summer :)
 

Registered
Joined
129 Posts
Discussion Starter · #13 ·
The quick defrost button puts the aircon on too (which dehumidifies) so that might be why you're cold. I try and avoid the button, the car is amazing and blows hot air within a mile of driving unlike all my previous vehicles which took about 7 miles at least.

If you're car is always misting up its probably full of moisture in the carpets and upholstery. Mine got like this recently, solution is to run the aircon with heat as required when driving around which will dry the car out, and don't leave wet coats in the back or boot etc.
 

Registered
Joined
626 Posts
Another HDiBlue driver here and got to say...it does take what seems like forever to warm up.

Yesterday it took a measured 8miles of a mix of stop start andclear runs at 0deg to get any noticable warmth out of the vents. The screen clears ok on start up but its the warmth I need once moving!
 

Registered
Joined
1,520 Posts
BristolRich said:
Another HDiBlue driver here and got to say...it does take what seems like forever to warm up.

Yesterday it took a measured 8miles of a mix of stop start andclear runs at 0deg to get any noticable warmth out of the vents. The screen clears ok on start up but its the warmth I need once moving!
There must be something wrong then

I have the HDI blue and heater is full blast (we use auto) and warming car nicely within 3 miles of home and that was at -1 this morning
 

Registered
Joined
472 Posts
Have got used to our heater controls finally, I find the whole system fine. Footwell heat is great, in front of feet and to the side. Everywhere else is ok aswell. I keep looking at the manual whenever I 'think' something isn't right and then spot something I didn't notice before and all becomes clear as to why it does/doesn't work as you expect it to. Surely there can't be a 'difference' to the heating systems depending on model ?. Or are some of these Cacti not being built consistantly the more time goes on, afterall all car manufacturers need human intervention, because humans are inconsistant thats where these problems could originate from. I'm just amazed (or very lucky) that ours has lived up to all expectations, upto now anyway. :) :?:
 

Registered
Joined
328 Posts
Rather stupidly, the foot well air vent is just below the cup holder. No wonder my feet are freezing, although my knees are toasty :lol:
 

Registered
Joined
472 Posts
Blactus said:
Rather stupidly, the foot well air vent is just below the cup holder. No wonder my feet are freezing, although my knees are toasty :lol:
Sorry I just don't get it, this morning windscreen covered in ice, sprayed de icer after pressing windscreen de mister button. Within 3 mins tops it was clear. Put footwell on, 3/4 fan and its blowing right at my feet, I even put my hand under glovebox and pedals and its blowing fine. Hate to say it but are your settings ok?. :?:
 

Registered
Joined
1,520 Posts
cactusjack said:
Have got used to our heater controls finally, I find the whole system fine. Footwell heat is great, in front of feet and to the side. Everywhere else is ok aswell. I keep looking at the manual whenever I 'think' something isn't right and then spot something I didn't notice before and all becomes clear as to why it does/doesn't work as you expect it to. Surely there can't be a 'difference' to the heating systems depending on model ?. Or are some of these Cacti not being built consistantly the more time goes on, afterall all car manufacturers need human intervention, because humans are inconsistant thats where these problems could originate from. I'm just amazed (or very lucky) that ours has lived up to all expectations, upto now anyway. :) :?:
Yes I was thinking the same. Are these cars being built to a consistent standard. Our car is also going great and a pleasure to drive own and use but you hear some on here who are having real bad problems...... Are we just Lucky :?
 

Registered
Joined
644 Posts
I knew we wouldn't have too many niggles with ours as someone else had driven it for the first 10k for us (the Citroen showroom manager). That (and the price!) is the advantage of an ex demo. Maybe he had a few teething problems but he would have just taken it into the service department at work and got it fixed.

Saying that maybe one day I'll have the luxury of getting a brand new car with only a handful of miles on the clock. :)
 
1 - 20 of 35 Posts
Top