Citroen C4 Cactus Crossover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I am finding a problem with cruise control. When the car reaches the programmed speed it appears to "hunt" around that speed rather than staying. stable. You can feel the engine pulling then going onto overrun in quick succession. Anyone else had this issue.
Also annoyingly when set at 60 in cruise the speedo reads 59 or 61.
 

·
Registered
Joined
·
32 Posts
I haven't noticed, mine tends to stop 1mph short of the set speed for a few seconds and then reads as per the setting. Except for when hitting a hill or a bend, it is very stable.

Chris.
 

·
Registered
Joined
·
15 Posts
Hello DC Hudson,

I couldn't monitor that behaviour you discribed. Mine also stays 1 km/h short of the set. I was surprise about the reliability of the cruise-function.

René
 

·
Registered
Joined
·
62 Posts
My cruise control seems remarkably accurate up to now. Also finding the speed limiting very useful as do a lot of journeys via m25 and A1. Lots of average speed checks now. Also there are new speed cameras on the M25 that ARE NOT advertised or connected to the overhead variable speed gantries. So setting the speed limiters are advisable. Think they are appearing round the M5/M6 Birmingham area as well so watch out.
 

·
Registered
Joined
·
7 Posts
Yep I noticed this slight surge at certain speeds on my 1.6 Blue Hdi, can be a bit uncomfortable for longer periods, luckily UK roads are too busy or messed with road works so long periods at a set speed are few & far between!!
 
1 - 6 of 6 Posts
Top