Citroen C4 Cactus Crossover Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hi All,
Just curious has anyone else had to have their entire screen/unit replaced due to "multimedia system unavailable" fault. I thought it might just need a reboot or update but the car has had to be booked in to replace the whole system.
 

·
Registered
Joined
·
472 Posts
Not heard of that one before, out of interest what model and year was it built?
 

·
Registered
Joined
·
169 Posts
JuliusMinshall said:
Hi All,
Just curious has anyone else had to have their entire screen/unit replaced due to "multimedia system unavailable" fault. I thought it might just need a reboot or update but the car has had to be booked in to replace the whole system.
Mine is doing this a lot, even at 12C temperatures. I can see a flaw in the screen when it is turned off. I have photo evidence of my problem, and will be presenting this to my dealer when the car goes for its first service in March. A replacement screen may be my solution, but I am prepared to have a firmware update to try and fix this issue.
 

·
Registered
Joined
·
2 Posts
I have a 1.6 blue hdi flair and had the smeg unit replaced last year. it went haywire at temperatures lower than 5 degrees C.
I live in the N/E of scotland
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
cactusjack said:
Not heard of that one before, out of interest what model and year was it built?
It is a Flair. It was built early 2015. I received it in April 2015.

The dealer seemed like it was no problem to just replace the unit. Perhaps it is a common fault. I think it might be to do with the colder weather.
 

·
Registered
Joined
·
2 Posts
I have had the screen replaced under warranty. There was som moisture or something caught between the layers of the screen, which made the touch sensitivity go nuts at cold temperatures.
No problems since.
 

·
Registered
Joined
·
472 Posts
Great that its been sorted, another problem solved easily and if anyone else gets the same problem we now know it can be sorted without too much trouble. Hopefully. ;)
 

·
Registered
Joined
·
129 Posts
The multimedia unit and electronic actuators for the heating will probably be the downfall of Cacti eventually, when they're all over 10 years old with faulty screens so you can't even have the heating or radio on!
 

·
Registered
Joined
·
472 Posts
Rattlegun said:
The multimedia unit and electronic actuators for the heating will probably be the downfall of Cacti eventually, when they're all over 10 years old with faulty screens so you can't even have the heating or radio on!
Based on what ??
 

·
Registered
Joined
·
1 Posts
I am just waiting for a new MM unit on my 4 month old flair. It's been on & off for weeks. They tried a reboot but now it has to be replaced. It's awful driving without it.
 

·
Registered
Joined
·
2 Posts
I had mine replaced on the warranty. Constantly getting the "Multimedia system unavailable" when it was near or under 0 C. The new one works perfectly.
 

·
Registered
Joined
·
316 Posts
I had a new unit in about a week ago. They didn't find any fault with it in the garage apart from upgrading. I took the car home and a few days later it was playing up again. Anyway I re booked it in. They had my car for 5 days and the Technical guy drove it round and it finally the fault appeared. The unit was replaced and is fine now and my old one is on its way to Spain.
 
1 - 15 of 15 Posts
Top