Citroen C4 Cactus Crossover Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Dear All,

I have an iPhone 4s, which I upgraded to iOS 9.3.1 and I'm experiencing a weird symptom with bluetooth calls, when I'm also listening to music streaming (iTunes) over bluetooth.

When I place a call, the car media system takes more time than it normally does to show the call progress information on the display (the message informing that an outgoing call is proceeding) and when it finally does it, music streaming is lost (the in-car system informs that music streaming has been disconnected), and the call proceeds but using the iPhone's handset speaker instead of the bluetooth handsfree.

If I try to place another call afterwards, it works properly. However, music streaming over bluetooth stays disconnected and needs a new device reconnection to work. This happens randomly but it seems to only occur when I'm using bluetooth audio streaming.

I have the latest SMEG firmware version.

Thanks for your help - any suggestion is welcome,
 

·
Registered
Joined
·
709 Posts
I have heard of similar problems with other cars/ phones being overcome by using the car Bluetooth settings menu to delete the pairing with the phone and then re-pairing .

After doing this (just once) the phone functions were correct.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
I tried that already, but it didn't work. But it doesn't hurt to try again.

Thanks for the advice!
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
I deleted the paring record from the phone and the car. Rebooted the phone (just in case) and repeated the association procedure. Since this issue occurs randomly, I had to give it a few tries but I was able to reproduce it again. So, it must be something else...
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
I have been studying the issue and did some more testing:

-on our other car, a C4 II, with bluetooth (it's not full-quality A2DP) this issue doesn't happen
-on the Cactus, I wasn't able to reproduce this problem with a samsung Galaxy Grand Neo
-on the Cactus, I'm not able to cause a handsfree disconnection if I avoid using audio streaming

This, together with the fact that I wasn't using the car during the week were I did the upgrades (upgraded to iOS 9.3 around the 28-30 March and to 9.3.1 on the 31 March) makes me very suspicious about the iOS upgrade. Unfortunately, I didn't drive the car because it was left at the dealer to solve a whistling noise and to perform a firmware upgrade on the SMEG system. So, there is also a chance of this being SMEG's fault - but nobody besides me seems to be complaining....
 

·
Registered
Joined
·
6 Posts
Hi there - just got my Cactus today, very happy with it in general, but a similar problem occurred on my first journey! :( My iPhone was connected but bluetooth music streaming dropped out after I took a call, and wouldn't connect again (the option wasn't selectable) until I turned the engine off and restarted the car. Has this issues been resolved for anyone yet?
 

·
Registered
Joined
·
253 Posts
I'm using iPhone 5s with ios 9.3.1 with no problems.
Did you try disconnecting and reconnecting the Bluetooth link from the iPhone's side?
 

·
Registered
Joined
·
6 Posts
This seems to have settled down a bit although I do keep having to re-add the phone for audio streaming every couple of days. Hopefully it'll get bored of losing it.
 
1 - 9 of 9 Posts
Top