Citroen C4 Cactus Crossover Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Just turned on car and screen is blank, tried manual off and on, nothing. All buttons illuminate. Any ideas if there is a reset or its looking like a visit to dealers. Obviously cannot select anything.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
Hi Claire, Turned on this morning and all was ok, will keep my eye on it and give feedback. Not much point in going to dealer while it is working.
 

·
Registered
Joined
·
644 Posts
Glad it's working but intermittent faults are the worst. Fingers crossed it was a momentary blip and will behave itself from now on!
 

·
Registered
Joined
·
316 Posts
The fault on my radio sorted itself out. I took it to the dealer and they could not find anything wrong. I was driving home and it started again. It has been ok ever since and that was 3 weeks ago.
 

·
Registered
Joined
·
116 Posts
My screen froze up yesterday...I was in Sainsburys car park storing some stations in the radio and it froze - I could call up the other functions eventually, but the radio refused to respond to anything ;just a blank screen. Gave up in the end and went and did the shopping - when I came out an hour later it was all fine! Hmmmmm......
 

·
Registered
Joined
·
316 Posts
I have that sometimes when I first start the car but only from cold, it is fine when the car warms up.
 

·
Registered
Joined
·
1,520 Posts
I think its because the screen is a computer and unfortunately computers freeze and crash - but the beauty of this system is Citroen can send out updates and fixes a lot easier than 'standard' cars with 'normal' displays etc. They could really change a lot of settings and functions within the limits of what hardware the car has installed
 

·
Registered
Joined
·
3 Posts
I have a 2014. The screen does not go pass the splash screen. Sometimes I can hear music playing, the buttons light up, but cannot select anything. Cannot find how to do a manual reboot/reset. Any ideas how to fix? I have an appointment with the dealership a week and not.looking forward to a big bill.
 

·
Registered
Joined
·
626 Posts
Have you disconnected the battery and left it for 30-60mins then reconnected?
 

·
Registered
Joined
·
340 Posts
When I had the firmware update done in October @ W.R.Davies in Stafford. The service manager had download a document from PSA that suggested that a 12-14 second boot up time was the normal time.
P.s. I highly recommend WRDavies.. As an independent Citroen Dealer great service.
 

·
Registered
Joined
·
626 Posts
No just your time and date settings.

Peripherals are programmed to the VIN of the car and require software to change them..
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top