ENGINE WARNING LIGHT NO ERROR CODE SHOWS IN OBD

Faults and Technical chat for the Citroen C4 Cactus
Post Reply
GarciasMuffin
Posts: 4
Joined: Sat Sep 12, 2020 11:59 am

ENGINE WARNING LIGHT NO ERROR CODE SHOWS IN OBD

Post by GarciasMuffin » Sat Sep 12, 2020 12:29 pm

Hi,

Firstly, hello to everybody and hope you're well and keeping safe.

I have a C4 Cactus Blue HDI 2015.

I have a few questions about an engine fult that started when I tirned on A/C and then progressed.

So, it used to be that when I turned on the A/C, within 1 minute or so the red "Engine fault have the vehicale repaired" appeared on the main display. The engine went into limp mode.

After reading this forum I could see that it matched the issue of low fan speed and there was a sensor to replace. I was a bit naughty and decided "ok, I'll do that in the future and just not use A/C for now". Lazy I know :(

However, now I have the same warning message without even using A/C. If I turn the engine off and on then it's good for 10 mins or so and then happens again. I know this could be due to a completely different issue butI thought that I'd replace the sensor anyway to see if it cleared the issue. The part number mentioned in the post was C1267J6/B1D3 and it cost approx £45. However, there is no mention of this part number when I google it. I would be grateful if somebody could post a link to where I can purchase this part.

Also, I have a fault diagnosis sensor which I can successfully connect to using a peice of software called "Car Scanner". However, this shows no fault codes. Even waiting for the fault to occur and then running the diagnostics shows zero faults. We have tried several pieces of software including "OBD Suto Doctor" but none show an error code. I believe that it should show an error code regardless of if the error is happening that moment because it should read the error code log and advise of errors that have not been set as resolved in the cars computer, is this corrrect ? Maybe the low fan speed sensor issue isn't something that would provide an error code ?

My other question is regarding the yellow "SERVICE" message on the dashboard. My car is due a service in 350 miles. Is this simply a warning that will show until I get the car serviced and the garage will tell the computer that the car has now been serviced and turn the light off or is the SERVICE showing due to the engine fault and shouldn't be on unless something has gone wrong with the car.

Thank you in advance for any help you can give.

Just wondered aswell if at any point in the design meetings anybody said "Instead of making the driver buy pieces of hardware to connect and download software we just write the error code to that massive screen in the middle of the car" ;)
Last edited by GarciasMuffin on Sat Sep 12, 2020 12:46 pm, edited 1 time in total.

GarciasMuffin
Posts: 4
Joined: Sat Sep 12, 2020 11:59 am

Re: ENGINE WARNING LIGHT NO ERROR CODE SHOWS IN OBD

Post by GarciasMuffin » Sat Sep 12, 2020 3:03 pm

Ok, I now have a better understanding of what's happened.

First, the yellow SERVICE light performs 2 functons. One is to warn you that there is a service due/overdue.

I reset the SERVICE light by using the "Press the left stalk end in" method.

This did clear it and the red spanner next to the service mileage.

However, I then drove the car and again the "Engine fault have the vehicle repaired" message showed again AND the service light came back on. So clearly the SERVICE light also serves as a "Your car is knackered" indicator.

Also, and more importantly.

I remember that my fan was really loud after I had made even my short journey to work.

I now see that the fan is never coming on no matter how far I drive, the engine has been running for approx 40 mins and I've driven it quite far.

So, I thought hopefully the fuse has blown, but no, it hasn't from what I can see. I am referring to the 60amp blue fuse in the engine compartment fuse box, so I'm going to assume for now that the temperature sensor that tells the fan to turn on is faulty.

Can somebody please tell me where this is on the car so I can order one and replace it ?

I'm having a frustrating time finding videos/manuals about fixing the Cactus :evil:

GarciasMuffin
Posts: 4
Joined: Sat Sep 12, 2020 11:59 am

Re: ENGINE WARNING LIGHT NO ERROR CODE SHOWS IN OBD

Post by GarciasMuffin » Sat Sep 12, 2020 5:04 pm

I now know there are 2 fuses not just one for the fan, both in the engine compartment fuse box.

One is the 60A blue large and the other a 5A fuse. Neither were blown :(

I cleaned the contacts on both just in case, but still nothing.

I then took the plastic ducting off which is on the right front side of the engine and noticed a box with a spring contraption in it which rests through a hole very close to the radiator fins.

Does anybody know if this object is the temperature sensor to bring the fan on. It does connect with wiring that looks like it connects to the fan ?

If it is, then it's the kind of thing some amateur science boffin would make in his shed in 1930's Britain to detect temperature which at least made me smile (well, that and my car having a glove box resembling a middle class families picnic hamper).

Although I'm thoroughly pissed by the fact that the complete lack of internet search results for anything to do with my car suggest only 3 people ever bought this car of which none would ever want to try fixing it and I'm one of those unlucky three.

Post Reply