Heating stopped?

Faults and Technical chat for the Citroen C4 Cactus
User avatar
weebugg
Posts: 33
Joined: Wed Mar 09, 2016 8:23 pm
Location: Glasgow

Heating stopped?

Post by weebugg » Mon Apr 04, 2016 4:18 pm

So went out today, and heating wasn't working? All functions worked ie speed, direction etc but would only blow cold air over a one hour drive...car was going into dealer anyway as one of the interior panels was damaged on delivery. Heating worked for them and now fine...anyone had similar?

The2ems
Posts: 643
Joined: Mon May 11, 2015 8:26 pm
Has thanked: 1 time

Re: Heating stopped?

Post by The2ems » Mon Apr 04, 2016 5:36 pm

Did you have the temperature control turned up?
PureTec 82 manual, Flair, Shark Grey, Black air bumps

User avatar
weebugg
Posts: 33
Joined: Wed Mar 09, 2016 8:23 pm
Location: Glasgow

Re: Heating stopped?

Post by weebugg » Mon Apr 04, 2016 5:48 pm

obviously...everything worked as it should - I could change where the air came from, the speed of the fan etc and when I turned temp down it got colder, but even on full heat was cold...I thought I was going mad, and wife agreed but no matter what she did we got same results. Had to drive nearly 50 miles with the "clear windscreen" button selected to keep the windscreen clear, but it only blew cold air (as soon as we turned it off the screen started to mist up and after a few minutes it was hazardous to drive) - I had to wear gloves to drive, and wear jacket fully done up!!

FrankBullitt
Posts: 354
Joined: Sat Nov 14, 2015 9:32 pm

Re: Heating stopped?

Post by FrankBullitt » Mon Apr 04, 2016 6:24 pm

This fault has existed on the C4 Picasso - it typically resets itself when the car is stopped, locked, opened and re-started - it is an issue with a controller that needs to be replaced; there is a technical bulletin for the Picasso, not sure of the number though but your dealer can lay their hands on it. However, whilst it is an inconvenience you can reset it as described above.

User avatar
weebugg
Posts: 33
Joined: Wed Mar 09, 2016 8:23 pm
Location: Glasgow

Re: Heating stopped?

Post by weebugg » Mon Apr 04, 2016 7:42 pm

Thanks FrankBullitt! Always concerns me when a dealer doesn't own up...we spoke to multiple people in service, although I am always willing to give the benefit of the doubt in case they haven't come across it before.

A quick search on Google actually showed up this viewtopic.php?f=11&t=129 so its certainly come up here before!

I have emailed the dealer and informed them that I have been made aware of the cause, feels good to be a bit smug :)

Thanks again

Chris

SITHEIL
Posts: 1
Joined: Wed Jul 27, 2016 4:17 pm

Re: Heating stopped?

Post by SITHEIL » Tue Feb 07, 2017 8:48 pm

Yes, this happened to me. No logic to this whatsoever. Drove home 15 miles with no heating. The next day everything working perfectly and has done ever since. Go figure.

User avatar
srperry
Posts: 186
Joined: Sun Apr 17, 2016 2:00 pm
Location: Wiltshire, UK

Re: Heating stopped?

Post by srperry » Wed Feb 08, 2017 2:47 pm

I had this problem too the other day - I was leaving Cheltenham at the end of the day, heater working fine. Received Bluetooth-connected phone call, and when at end of call the caller terminated the call the heater started chucking out bitterly cold air and wouldn't warm up whatever settings I used (normally I have climate control ON at all times set to a warm temperature). After some miles I stopped in a lay-by and turned the car off for a couple of minutes, then restarted and everything was working again normally. It hasn't happened since.

My garage thinks it's a software glitch.
PureTech 110 S&S Flair, Polar White/Black Bumps, Black Leather/Cloth with Stone Grey ambience + CityPark and BlackVue DR650GW-2CH Front & Rear cameras

User avatar
SAP
Posts: 24
Joined: Tue Mar 08, 2016 9:13 am
Location: Salford

Re: Heating stopped?

Post by SAP » Wed Feb 08, 2017 4:17 pm

It's happened to me once also. It was blowing cold air and the air con wouldn't switch off, even when full heat was selected. Never happened since, almost a year old now.
C4 Cactus 1.2i PureTech 110 S&S Flair Black, Red Mirrors & Red Rear Insert

Mark
Posts: 316
Joined: Sat Apr 04, 2015 11:00 am

Re: Heating stopped?

Post by Mark » Thu Feb 09, 2017 10:15 am

My heater does not work when the fan is off. It immediately gets cold air running through it.
Citroen C4 Cactus Sport Red with black bumps and Silver 17"wheels 1.6 eHdi 92 ETG6 Flair.

User avatar
termit
Posts: 7
Joined: Tue Mar 14, 2017 3:15 pm
Location: Sweden

Re: Heating stopped?

Post by termit » Tue Mar 14, 2017 3:44 pm

Hi folks! Today I experienced the same issue on my 11-months old cactus here in Sweden. In the morning everything was fine but after a short visit in a store the air became cold, regardless to which temperature I adjusted on the screen :?: :?: :?: Both manual & auto. I called the service immediately on the way home, they did not know what I was talking about :roll: They would have a look on that on Monday but the problem disappeared after a 10-minutes long stop and the air became hot again. At home I connected my computer to the ODB2 socket but no faults could be read, everything was fine. Now I read I'm not alone :D We'll see if the issue will come back in the future but hopefully not! :P

Anybody experienced this issue more than once so far?
C4 Cactus 1.2 PureTech 82 S&S ETG Happy Edition
Hello Yellow, Black Bumps, Black "Square" Wheels

Image Image

Post Reply