Engine fault.

Faults and Technical chat for the Citroen C4 Cactus
Post Reply
Rubik
Posts: 76
Joined: Sat Jun 04, 2016 10:22 pm

Engine fault.

Post by Rubik » Fri Feb 16, 2018 8:04 pm

Cactus Feel, diesel, 1.6hdi manual in lovely Hello yellow.

I was out today, no issues with the car. Parked in a carpark for a couple of hours but when I returned and turned the key:-

An immediate red warning filled the display screen, a red engine symbol saying engine fault and to stop.

I hadn't even started the engine. I turned the key and the engine immediately started then stopped (similar to stop/start). Hmm.

I turned the ignition off and back on, the same red warning message. Being baffled I telephoned my Citroen agent to describe the issue and repeat the manoeuvre, then the warning message didn't re-appear. The engine then started, management light went out including other usual warning lights. The car functioned perfectly the rest of the day including the stop/start.

Has anyone else experienced this? A glitch in the start up management system?


richtea141
Posts: 2
Joined: Tue Mar 06, 2018 7:55 pm

Re: Engine fault.

Post by richtea141 » Tue Mar 06, 2018 8:00 pm

Had this today.
Car fine in morning.

Car parked at work all day.
At home time went to start car, 'Engine Fault-Do not start car' Red warning sign appeared on touchscreen.

Took key out and tried again 8+ times.
Tried starting the car too and car tries to start but doesnt get going.

Car now stuck at work 😢

Anyone had similar problem.


Pheon
Posts: 31
Joined: Thu Aug 31, 2017 9:04 pm

Re: Engine fault.

Post by Pheon » Wed Mar 07, 2018 6:17 pm

What engine?


Rubik
Posts: 76
Joined: Sat Jun 04, 2016 10:22 pm

Re: Engine fault.

Post by Rubik » Thu Mar 08, 2018 2:22 pm

Yes, I have had the same issue, I have mentioned it on the forum but nobody replied. Nobody was particularly interested at that time.

I had just parked up to do some shopping and on my return this message appeared in the display. The car was working fine up to that point.
The engine started but immediately stopped. I rang the garage who said it could just be a glitch. I tried to start the engine again but after about 4 attempts, all the lights went out as they should, the car has worked well ever since with no further issues even through the minus temperatures.


xireland
Posts: 57
Joined: Thu Nov 03, 2016 3:38 pm

Re: Engine fault.

Post by xireland » Fri Apr 06, 2018 12:18 pm

Well today while I was driving I got that error engine fault and red alert message see the pic
the fact is I went to I dealer straight after and they say they will look at it next week as they are busy, then I call Citroen assistant and I explain the situation and then they told since I have book in they can not help me. Then I complain and they give the main office's number which I call them and explain again...
I am waiting .......

engine fault (2).jpg



xireland
Posts: 57
Joined: Thu Nov 03, 2016 3:38 pm

Re: Engine fault.

Post by xireland » Fri Apr 06, 2018 3:04 pm

so the OBD diagnostic shows
P20F6 Reductant Injection Valve Stuck Open (Bank 1 Unit 1)

error


C4ACF
Posts: 2
Joined: Sat Apr 07, 2018 7:07 pm

Re: Engine fault.

Post by C4ACF » Sat Apr 07, 2018 7:22 pm

Hi. Have you managed to sort out this problem.
Today same thing happened to me. The warning displayed on touchscreen then goes off but engine warning light on instrumental panel remains displayed.
I am honestly afraid to drive it thinking that it might cause costly damages


xireland
Posts: 57
Joined: Thu Nov 03, 2016 3:38 pm

Re: Engine fault.

Post by xireland » Fri Apr 13, 2018 1:28 pm

I think was only the adblue for me as the message is gone
But the normal car service in an official Citroen dealer for 60000 km full service i paid 380 euros In Dublin !!!!
just a service imagine if i had a fault!


jacques38
Posts: 189
Joined: Mon Jun 13, 2016 4:05 pm

Re: Engine fault.

Post by jacques38 » Fri Apr 13, 2018 3:10 pm



C4ACF
Posts: 2
Joined: Sat Apr 07, 2018 7:07 pm

Re: Engine fault.

Post by C4ACF » Fri Apr 20, 2018 4:47 am

I had the emission reservoir replaced. Dealer said it was a faulty sensor but to be sure they replaced the lot. I hope the diagnosis was correct as I felt it was a bit of a trial and error.


Post Reply

Return to “Faults & Technical”